CVE CVE-2021-21781 | Linux Kernel v5.4.66 and v5.4.54 Information Disclosure Vulnerability

References
Description
An information disclosure vulnerability exists in the ARM SIGPAGE functionality of Linux Kernel v5.4.66 and v5.4.54. The latest version (5.11-rc4) seems to still be vulnerable. A userland application can read the contents of the sigpage, which can leak kernel memory contents. An attacker can read a process’s memory at a specific offset to trigger this vulnerability. This was fixed in kernel releases: 4.14.222 4.19.177 5.4.99 5.10.17 5.11
Note: References are provided for the convenience of the reader to help distinguish between vulnerabilities. The list is not intended to be complete.

Continue reading...
 
Top